Nowość: Włącz alerty cenowe na e-booki i kupuj taniej!

Masz Windows XP i używasz Calibre? Pozostań przy wersji 1.48

Tydzień temu ukazała się wersja 2.0 popularnego programu Calibre do konwersji i zarządzania książkami elektronicznymi – czemu poświęciłem osobny artykuł.

Było kilka doniesień o problemach w działaniu tego programu na starszym sprzęcie. Calibre 2.x używa środowiska QT5, która okazało się być niekompatybilne z Windows XP.

Dlatego wersja Calibre 2.1, która ukazała się dzisiaj, nawet się na starym systemie nie zainstaluje, jak pisze autor w sekcji „Co nowego”:

Prevent calibre from installing or running on Windows XP as there have been many reports of Qt 5 crashing on Windows XP and Windows XP is now no longer supported by Microsoft. If you are on Windows XP, please stay with calibre 1.48 until you are ready to upgrade your windows.

Jeśli używamy wciąż XP trzeba pozostać przy wersji Calibre 1.48 która jest ostatnią, która działa poprawnie z tym systemem. Jeśli zainstalowaliśmy w międzyczasie wersję 2.0 – można ją odinstalować i z powrotem zainstalować 1.48 – nasze książki i ustawienia zostaną niezmienione.

Korzystającym z Windows Vista, 7 lub 8 w wersji 64-bitowej przypomnę przy okazji, że program możemy ściągnąć w dwóch edycjach – 32-bitowej i 64-bitowej. Ta druga daje, przynajmniej w moim przypadku, poprawę wydajności o blisko 10 procent.

Calibre odwdzięczy się też podkręcającym procesory – oto notatki, które zapisałem sobie kiedyś bawiąc się mnożnikiem mojego 2500K – jako benchmark używałem dużej książki z O’Reilly, której konwersja z EPUB do MOBI zajmuje sporo czasu.

Stary procesor (E5200 @3.2 GHz)  4:10 min
2500K@3.3:  2:30 min
2500K@3.9: 1:54 min
2500K@4.1: 1:44 min
2500K@4.3: 1:39 min (+51%)
2500K@4.5: 1:32 min
Wersja 64bit @4.5: 1:20 min

Program przyjmie zatem każdą dodatkową moc z procesora.

PS. Uzupełnienie na podstawie komentarzy – to samo dotyczy użytkowników Mac OS X 10.5 albo 10.6 – ostatnią używalną wersją jest 1.48.

Czytaj dalej:

Artykuł był przydatny? Jeśli tak, zobacz 6 sposobów, na jakie możesz wspomóc Świat Czytników. Dziękuję!

Ten wpis został opublikowany w kategorii Książki na czytniki i oznaczony tagami . Dodaj zakładkę do bezpośredniego odnośnika.
Hosting: Zenbox

40 odpowiedzi na „Masz Windows XP i używasz Calibre? Pozostań przy wersji 1.48

  1. Rafał pisze:

    Witam,

    Właśnie a czy ktoś spotkał się z problemem wtyczki APNX Generator opisanej np tutaj:
    http://swiatczytnikow.pl/trzy-sposoby-na-liczbe-stron-w-ebookach-mobi/
    na Calibre 2? Wygląda na to, że ikona z paska narzędzi gdzieś znikła, pomimo tego, że wtyczka jest zainstalowana poprawnie — i aktualnie nie mogę uruchomić wtyczki ręcznie dla plików mobi z dysku…

    Pozdrawiam,
    Rafał

    0
  2. midar pisze:

    Wiele osób korzysta z Mac, więc warto dodać, że „If you are using OS X 10.5 or 10.6, the last version of calibre that will work on your machine is 1.48, available here”.

    0
  3. kjonca pisze:

    Dlaczego „konwersji”? Ja calibre używam jako zarządcy biblioteki.

    0
    • hipciu pisze:

      Ja też, wygodniej się przegląda okładki książek zamiast folderów z nazwami.

      0
    • KonradK pisze:

      Jeśli ktoś ma w bibliotece tylko ebooki w formacie strawnym dla posiadanego czytnika, to tak może.
      Mam sporo RTFów i EPUBów, z których niektóre chciałbym przeczytać na Kindle DX. W praktyce nie korzystam z ebook-convert.exe, podpiętego pod menedżera plików. Wolę wpierw ściągnąć metadane i okładkę, aby znalazły się w przekonwertowanym do MOBI ebooku.

      0
  4. Piotrek pisze:

    Ja mam szacownego XP-ka i Calibre w wersji 1.7 działa bezproblemowo (przynajmniej jeśli chodzi o podstawy – konwersja plików, pobieranie newsów itd.) Co do reszty to nie testowałem;)

    0
  5. rudy102 pisze:

    Widzę, że pomimo wydania wersji 2 ten upośledzony program na Windowsie nadal nie potrafi się sam aktualizować, tylko raz na tydzień trzeba ściągać ze strony i instalować…

    0
    • Robert Drózd pisze:

      Jak zgłaszali to autorowi w bugtrackerze, to on zamykał zgłoszenie i twierdził, że tak ma być, bo programu nie należy aktualizować co tydzień…

      0
      • Wojciech pisze:

        Skoro „nie należy” to dlaczego wypuszcza nową wersję co tydzień?

        0
        • KonradK pisze:

          Może aby testerzy i inni uważający inaczej, na tyle zdeterminowani, żeby samodzielnie ściągać co tydzień instalator, mieli jakąś opcję . Bez zachęcania do tego pozostałych przez umieszczenie funkcji Update w programie.

          0
    • zipper pisze:

      a zapłaciłeś za ten program? Nie? Więc może odrobina szacunku dla twórcy?

      0
    • bastard pisze:

      Po co się męczysz używając upośledzonego programu?
      Odinstaluj i nie zaśmiecaj komentarzy swoim zrzędzeniem.

      0
  6. Cyber Killer pisze:

    To raczej na 99% nie jest wina Qt5, a samego Calibre. Samo Qt śmiga na winxp, bajki o (nie)supportowaniu przez microsoft można sobie darować.

    0
    • Maks pisze:

      QT5 winne, przynajmniej w tej kwestii, że bez względu na system WinXP czy Win7 nie uruchomi się aplikacji. Wymagany procesor z isntrukcjami SSE2 (czyli np. nie pójdzie na AMD Athlon XP 2500+, ale pójdzie na Pentium 4 2Ghz)
      Kovid być może uprościł komunikat, bo mało kto wie jakie instrukcje obsługuje procesor, a że Win 7 nowszy, to prawdopodobnie ma już procesor z SSE2.

      0
      • Cyber Killer pisze:

        No, ale to wystarczy sobie przekompilować, żeby wyłączyć wymaganie SSE2 jak przeszkadza i gotowe. A, wróć, to przecież legacy OS, tu kompilacja to trudna sprawa ;-D.

        0
  7. KonradK pisze:

    Program przyjmie zatem każdą dodatkową moc z procesora

    No, ale więcej wątków/rdzeni przy konwersji pojedyńczej książki to już chyba nie. Przynajmniej ebook-convert.exe nie wychylił się na moim C2Q 6600 poza 25% wykorzystania CPU.

    0
  8. kolo pisze:

    Kiedy konfa Amazonu ??

    0
  9. fredoslaw pisze:

    Ja mam XP i 2.0, wszystko działa (wszystko to troche na wyrost, korzystam pewnie z ułamka dostępnych funkcji). Czym konkretnie miałby objawić się konflikt i nieadekwatność?

    0
    • R pisze:

      „Dlatego wersja Calibre 2.1, która ukazała się dzisiaj, nawet się na starym systemie nie zainstaluje”
      Objawia się tym że się nie instaluje :D.
      Jeśli ci chodzi, to nie szukaj błędu tylko się ciesz i nie aktualizuj.

      0
      • fredoslaw pisze:

        Na dziś nie ma to większego znaczenia bo różnice są pomijalne, ale w przyszłości użytkownicy XP zostaną ze starym programem, nie uwzględniającym np. nowych czytników i rozwiązań.

        0
        • R pisze:

          Nie ukrywajmy już tak jest, i działa to w obie strony, aby użyć mojego skanera, muszę uruchamiać na komputerze wirtualnego XP.
          Firmom nie opłaca się wspierać 13 letniego XP, który już jest ułamkiem zainstalowanych systemów komputerowych.

          0
          • fredoslaw pisze:

            Wszystkie systemy są ułamkiem pełnej puli. XP jest nadal jednym z większych. Ja nie planuję przesiadki bo właśnie skaner, bo inne rzeczy bez sterowników, bo w końcu porządny nowoczesny system 64 bitowy realnie wymaga tych 4GB pamięci (używam gdzie indziej na 2GB i to jest koszmar), a u mnie nie da się rozbudować bez wymiany praktycznie wszystkich bebechów. Dla mnie w dalszym ciągu za dużo strat i wydatków, za mało zysków.

            0
          • KonradK pisze:

            Jest taki program – VueScan – który komunikuje się ze skanerami, bez pośrednictwa (więc i bez potrzeby posiadania) sterownika.

            0
            • fredoslaw pisze:

              O, to ciekawe, program znam. Teraz tylko zorientować się czy karta SCSI ma sterownik (po krótkim rekonesansie – nie za bardzo).

              0
      • KonradK pisze:

        No właśnie. Skoro wersja 2.0 działa u niektórych użytkowników XP, to może powodem problemów jest coś bardziej specyficznego niż ten system.
        Być może autor Calibre wie lepiej, ale tylko „być może”. To, że nie zablokował możliwości instalacji na XP już w wersji 2.0, wskazuje na to, że nie ma pełnego rozeznania co do wymagań Qt 5. Na pewno nie miał w momencie publikowania wersji 2.0 , mimo tego, że beta 2.0 była dostępna jakiś czas wcześniej dla testerów.

        0
  10. carac pisze:

    Jeśli chodzi o „wszystko” działa, to nie działają takie pluginy jak lubimyczytac, ksiazka.wp – jedyny dostępny do sciągania metadanych o książce to google i amazone. Czy to tylko u mnie tak w nowej wersji 2.0? Mam co prawda win7, instalacja przebiegła normalnie, ale nie działają wymienione pluginy, co w wersji wcześniejszej calibre działało bez zarzutu.

    0
  11. makpfi pisze:

    Na moim xp-ku wersja 2.0 działała bardzo dobrze. Piszę, działała, bo właśnie dziś przestała, i już nie dała się odpalić. Na szczęście po odinstalowaniu i ponownym zainstalowaniu 1,48 ksiązki są.

    0
  12. złazmiana pisze:

    Miałam XP i używałam wersji powyżej 1.48 i wszystko śmigało. Przestawiłam na Win 7 i nowszy Calibre zaczęły problemy. Najpierw przestał pobierać okładki, a po ostatniej aktualizacji przestał pobierać opisy. Program stał się bezużyteczny. :(

    0

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Przed dodaniem komentarza zapoznaj się proszę z zasadami komentowania. Jeśli chcesz mieć swój obrazek przy podpisie, zarejestruj swój adres mailowy na stronie gravatar.com.

Zapisz się także do newslettera Świata Czytników


Komentarze do tego artykułu można śledzić także w formacie RSS.